User Tools

Site Tools


ccnp:dmvpn

This is an old revision of the document!


DMVPN w/ GRE

GRE tunnels, but dynamic, yanno?

Going to skip the explanation until I hit this part in the books, but until then - a refresher on quick Phase 2 configuration from a Hub/spoke topology with one HUB. And excuse the terrible diagram, I'll build a better one one I'm not pressed for time!

REFER TO THE ABOVE DIAGRAM AND NOTE THE CONFIGS BELOW!

CONFIGS

R1 the HUB

interface Tunnel10
 ip address 192.168.1.1 255.255.255.0  <-- Tun Addr
 no ip redirects
 ip nhrp network-id 1         <-- Activates NHRP
 tunnel source Loopback0
 tunnel mode gre multipoint   <-- Enable DMVPN
end

R3 Spoke

interface Tunnel10
 ip address 192.168.1.3 255.255.255.0    <-- Set IP for Tun INT
 no ip redirects
 ip nhrp map 192.168.1.1 1.1.1.1         <-- Map Phys address for NHS aka How do I get to 192.168.1.1?
 ip nhrp network-id 3                    <-- Useful for multi-hub environments. Details later...
 ip nhrp nhs 192.168.1.1                 <-- Specify NHS for tunnel traffic to traverse.
 tunnel source Loopback0                
 tunnel mode gre multipoint              <-- Enable Dynamic Multipoint VPN
end

R5 Spoke

interface Tunnel10
 ip address 192.168.1.5 255.255.255.0
 no ip redirects
 ip nhrp map 192.168.1.1 1.1.1.1
 ip nhrp network-id 5
 ip nhrp nhs 192.168.1.1
 tunnel source Loopback0
 tunnel mode gre multipoint
end
ccnp/dmvpn.1699760092.txt.gz · Last modified: 2023/11/12 03:34 by 114.119.144.233